Pages

Friday, May 23, 2014

Error: "To export a list, you must have a Microsoft SharePoint Foundation-compatible application"

Symptoms:
When trying to export a list from SharePoint 2010, you get an error message:
To export a list, you must have a Microsoft SharePoint Foundation-compatible application.
You have Office 2013 products (32 bit) installed, but it was upgraded from 2010 products.

Issue:
Since you have had multiple versions of office installed, there are multiple folders installed for it and SharePoint doesn't see anything in the 2010 folder on the client machine - because it was moved to the 2013 folder.  There is a fix outlined here for machines that don't have SharePoint Designer, OneNote or InfoPath installed, but otherwise does not work.

But there is a note at the bottom of that article that will fix this if you do have those installed.

Solution:
Modify the registry.
  • Click on the start menu, type regedit and then click OK.
  • Under Computer, HKEY_CLASSES_ROOT, find the SharePoint.OpenDocuments.5 key and right click.  Choose Rename.  Name it SharePoint.OpenDocuments.5.old and click ok.
  • The key will be re-added any time you repair/update the Office 2013 program and will have to be renamed/deleted again.

No comments:

Post a Comment